Fork me on GitHub

Opened 4 years ago

Closed 4 years ago

#1071 closed Bug (fixed)

Pythia8 in Delphes does not hadronize, returns error

Reported by: amin83 Owned by:
Priority: major Milestone:
Component: Delphes code Version: Delphes 3
Keywords: Cc:

Description (last modified by pavel)

Dear Delphes team,

I am trying to generate a Minbias.root file using Pythia8223 in MG5. I have the newest Pythia8 and MG 2.5.2. Using ./DelphesPythia8 cards/converter_card.tcl examples/Pythia8/generatePileUp.cmnd MinBias?.root, I am getting this message in the end:

*-------  PYTHIA Error and Warning Messages Statistics  ----------------------------------------------------------* 
 |                                                                                                                 | 
 |  times   message                                                                                                | 
 |                                                                                                                 | 
 |      1   Error in Pythia::next: hadronLevel failed; try again                                                   | 
 |      1   Error in StringFragmentation::fragment: stuck in joining                                               | 
 |      1   Warning in JetMatchingMadgraph:init: Madgraph merging parameters not found                             | 
 |      1   Warning in JetMatchingMadgraph:init: No alpsfact                                                       | 
 |      1   Warning in JetMatchingMadgraph:init: No ickkw                                                          | 
 |      1   Warning in JetMatchingMadgraph:init: No maxjetflavor                                                   | 
 |      1   Warning in JetMatchingMadgraph:init: No xqcut                                                          | 
 |      3   Warning in MultipartonInteractions::init: maximum increased                                            | 
 |      5   Warning in SpaceShower::pT2nextQCD: weight above unity                                                 | 
 |      2   Warning in StringFragmentation::fragmentToJunction: bad convergence junction rest frame                | 
 |                                                                                                                 | 
 *-------  End PYTHIA Error and Warning Messages Statistics  ------------------------------------------------------* 
** Exiting...

The Minbias.root file is generated but it is not complete. It only has the Events and particle branches in there.
Hope you can help me in that.

Best,
Amin

Change History (6)

comment:1 Changed 4 years ago by pavel

  • Description modified (diff)

comment:2 Changed 4 years ago by pavel

Dear Amin,

I've just tried to run ./DelphesPythia8 cards/converter_card.tcl examples/Pythia8/generatePileUp.cmnd MinBias.root with Pythia 8.223 downloaded from the Pythia web site and it worked without errors. Maybe the problem is in the Pythia version that comes with MadGraph.

MinBias.root is expected to have only the Event and Particle branches.

MinBias.root can be converted to MinBias.pileup with the following command:

./root2pileup MinBias.pileup MinBias.root

MinBias.pileup can be used with the *_PileUp.tcl cards as described in WorkBook/PileUp.

Best regards,

Pavel

comment:3 Changed 4 years ago by amin83

Dear Pavel,

Thanks for the reply.
I did not use the Pythia version that comes with Madgraph. I used the one from Pythia website.
I followed the instructions given on the Delphes website to install Pythia8 and connect it to Delphes. Now that I am getting the same ROOT file as you did, I'm not sure I understand the error that Pythia is throwing.
I have seen another bug report online (https://bugs.launchpad.net/mg5amcnlo/+bug/1622747) suggesting that this error is a normal occurrence. What's your take on that?
Thanks a lot.

Best,
Amin

comment:4 Changed 4 years ago by pavel

I've just retried with 100k events and obtained some errors. However, the program has terminated correctly and the output file contains 100k events.

If you are looking for more information about these errors, then I'd suggest to contact the Pythia developers.

comment:5 Changed 4 years ago by amin83

Ok, sounds good.
Thanks for the help.

Best,
Amin

comment:6 Changed 4 years ago by pavel

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.