Fork me on GitHub

Opened 6 years ago

Closed 6 years ago

#340 closed Bug (fixed)

LHCO segmentation fault

Reported by: jaraque Owned by: Pavel Demin <pavel.demin@…>
Priority: minor Milestone:
Component: Delphes code Version: Delphes 3
Keywords: Cc:

Description

Hi,

everytime I try to run delphes it creates the output root file and then it creates an LHCO file (which I usually don't use). When it start running that part this error happens:

Reading delphes.root
Input file contains 30000 events

* Break * segmentation violation

===========================================================
There was a crash.
This is the entire stack trace of all threads:
===========================================================
#0 0x00000030b4c9a075 in waitpid () from /lib64/libc.so.6
#1 0x00000030b4c3c741 in do_system () from /lib64/libc.so.6
#2 0x00002b7617cc5ecf in TUnixSystem::StackTrace?() () from /exports/home/jaraque/rootlib/libCore.so
#3 0x00002b7617cc7b0c in TUnixSystem::DispatchSignals?(ESignals) () from /exports/home/jaraque/root
lib/libCore.so
#4 <signal handler called>
#5 0x00000000006335af in LHCOWriter::LHCOWriter(ExRootTreeReader?*, _IO_FILE*) ()
#6 0x0000000000484888 in main ()
===========================================================

The lines below might hint at the cause of the crash.
If they do not help you then please submit a bug report at
http://root.cern.ch/bugs. Please post the ENTIRE stack trace
from above as an attachment in addition to anything else
that might help us fixing this issue.
===========================================================
#5 0x00000000006335af in LHCOWriter::LHCOWriter(ExRootTreeReader?*, _IO_FILE*) ()
#6 0x0000000000484888 in main ()
===========================================================

Do you know what could be the issue? I am just using the delphes card for ATLAS which comes in Madgraph chaging some jet variables. Is there something that I can do to test why this is happening?

Thanks a lot,
Juanpe.

Change History (5)

comment:1 Changed 6 years ago by jaraque

Just a comment, I am comenting these branches, which I thought has no effect appart from avoiding some information to be written in the output TTree but maybe this is causing the error?

#add Branch InputArray? BranchName? BranchClass?
add Branch Delphes/allParticles Particle GenParticle?

#add Branch TrackMerger?/tracks Track Track
#add Branch Calorimeter/towers Tower Tower

#add Branch Calorimeter/eflowTracks EFlowTrack Track
#add Branch Calorimeter/eflowPhotons EFlowPhoton Tower
#add Branch Calorimeter/eflowNeutralHadrons EFlowNeutralHadron Tower

add Branch GenJetFinder?/jets GenJet? Jet
add Branch UniqueObjectFinder?/jets Jet Jet
add Branch UniqueObjectFinder?/electrons Electron Electron
add Branch UniqueObjectFinder?/photons Photon Photon
add Branch UniqueObjectFinder?/muons Muon Muon
add Branch MissingET/momentum MissingET MissingET
add Branch ScalarHT/energy ScalarHT ScalarHT

Thanks again!
Juanpe.

Last edited 6 years ago by jaraque (previous) (diff)

comment:2 Changed 6 years ago by pavel

Hi Juanpe,

root2lhco converter needs the Track and Tower branches.

If these branches are not in the ROOT tree/file, then it crashes with the following error message:

** Reading delphes_output.root
** Input file contains 1000 events
** WARNING: cannot access branch 'Track', return NULL pointer

 *** Break *** segmentation violation

If you don't need the LHCO file, then I'd propose to just ignore this error.

Regards,

Pavel

comment:3 Changed 6 years ago by jaraque

Hi Pavel,

thanks. Since I don't need it I can just ignore the segmentation fault? I would like not to add those branches since I don't think I will need them and I would like to save some disk space.

Cheers,
Juanpe.

comment:4 Changed 6 years ago by pavel

The lhco2root converter now checks if the input ROOT file contains all required branches.

Otherwise, it cleanly exits with the following error message:

** WARNING: cannot access branch 'Track', return NULL pointer
** ERROR: ROOT file doesn't contain all required branches

comment:5 Changed 6 years ago by Pavel Demin <pavel.demin@…>

  • Owner set to Pavel Demin <pavel.demin@…>
  • Resolution set to fixed
  • Status changed from new to closed

In c59be54d73336cc84c0214fb6ea993f7d03f5f66/git:

check if ROOT file contains all required branches (close #340)

Note: See TracTickets for help on using tickets.