Fork me on GitHub

Opened 3 months ago

Closed 3 months ago

#1426 closed Bug (fixed)

Problem installing delphes 3.2.0 using make

Reported by: jakoblundst Owned by:
Priority: minor Milestone:
Component: Delphes code Version: Delphes 3
Keywords: make error Cc:

Description (last modified by pavel)

Hi,
When I try to install delphes I get the following error message:

~/MG5_aMC_v2_7_2/Delphes-3.2.0$ make
>> Compiling tmp/external/ExRootAnalysis/ExRootAnalysisDict.cc
In file included from /home/jakob/root/include/ROOT/TIOFeatures.hxx:19:0,
                 from /home/jakob/root/include/TTree.h:30,
                 from /home/jakob/root/include/TChain.h:24,
                 from external/ExRootAnalysis/ExRootTreeReader.h:14,
                 from tmp/external/ExRootAnalysis/ExRootAnalysisDict.cc:12:
/usr/include/c++/7/sstream:300:7: error: ‘struct std::__cxx11::basic_stringbuf<_CharT, _Traits, _Alloc>::__xfer_bufptrs’ redeclared with different access
       struct __xfer_bufptrs
       ^~~~~~
Makefile:2004: recipe for target 'tmp/external/ExRootAnalysis/ExRootAnalysisDict.o' failed
make: *** [tmp/external/ExRootAnalysis/ExRootAnalysisDict.o] Error 1

Not sure which type this error falls into. What do I do?

Change History (7)

comment:1 Changed 3 months ago by pavel

  • Description modified (diff)

comment:2 Changed 3 months ago by pavel

Please provide more details about your setup. What is the ROOT version, how ROOT was installed, what is the OS version?

Looking at the error message, I'd say that something is wrong with the ROOT installation.

comment:3 Changed 3 months ago by jakoblundst

I using ROOT 6.2.0 on ubuntu 18. I installed ROOT using by downloading the binary and :

sudo apt-get install git dpkg-dev make g++ gcc binutils libx11-dev libxpm-dev \
        libxft-dev libxext-dev
tar -xf root_v6.20.02.Linux-ubuntu14-x86_64-gcc7.5.tar.gz
echo source ~/root/bin/thisroot.sh >> ~/.bashrc

then I used

source <path way>/bin/thisroot.sh

to get delphes to "see" ROOT.

comment:4 follow-up: Changed 3 months ago by pavel

Thanks for the information.

tar -xf root_v6.20.02.Linux-ubuntu14-x86_64-gcc7.5.tar.gz

The name of the .tar.gz file looks strange. Isn't it root_v6.20.02.Linux-ubuntu18-x86_64-gcc7.5.tar.gz?

Anyway, I've just downloaded ROOT 6.20 for Ubuntu 18 from this link and tried to build Delphes 3.2.0 and 3.4.2.

With Delphes 3.2.0, I can reproduce the error message. A workaround is to copy Delphes-3.4.2/doc/genMakefile.tcl to Delphes-3.2.0/doc/genMakefile.tcl and rerun ./configure. Then there is a problem while compiling classes/DelphesFormula.cc that I don't know how to solve easily.

I can build Delphes 3.4.2 without problem. So, the easiest solution would be to switch to Delphes 3.4.2.

comment:5 in reply to: ↑ 4 Changed 3 months ago by jakoblundst

Replying to pavel:

Thanks for the information.

tar -xf root_v6.20.02.Linux-ubuntu14-x86_64-gcc7.5.tar.gz

The name of the .tar.gz file looks strange. Isn't it root_v6.20.02.Linux-ubuntu18-x86_64-gcc7.5.tar.gz?

Anyway, I've just downloaded ROOT 6.20 for Ubuntu 18 from this link and tried to build Delphes 3.2.0 and 3.4.2.

With Delphes 3.2.0, I can reproduce the error message. A workaround is to copy Delphes-3.4.2/doc/genMakefile.tcl to Delphes-3.2.0/doc/genMakefile.tcl and rerun ./configure. Then there is a problem while compiling classes/DelphesFormula.cc that I don't know how to solve easily.

I can build Delphes 3.4.2 without problem. So, the easiest solution would be to switch to Delphes 3.4.2.

Ok, thanks.

comment:6 Changed 3 months ago by pavel

Looks like copying DelphesFormula and DelphesTF2 from Delphes 3.3.0 to Delphes 3.2.0 solves the remaining compilation problem. Here is a link to Delphes 3.2.1 that can be built with ROOT 6.20 on Ubuntu 18:

http://cp3.irmp.ucl.ac.be/downloads/Delphes-3.2.1.tar.gz

For information, Delphes 3.3.0 was the first version compatible with ROOT 6.

comment:7 Changed 3 months ago by pavel

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.