Fork me on GitHub

Opened 4 months ago

Closed 4 months ago

Last modified 4 months ago

#1305 closed Bug (fixed)

Problems While Installing delphes

Reported by: sayan.saha Owned by:
Priority: major Milestone:
Component: Delphes code Version: Delphes 3
Keywords: Cc:

Description (last modified by pavel)

While I am running the make command after running ./configure I am getting may warnings and at last I am getting error like

>> Building libDelphes.so
>> Building hepmc2pileup
>> Building lhco2root
>> Building pileup2root
>> Building root2lhco
/usr/bin/ld: warning: libpng16.so.16, needed by //home/sayan/anaconda2/lib/libfreetype.so.6, not found (try using -rpath or -rpath-link)
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_create_read_struct@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_set_interlace_handling@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_get_io_ptr@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_set_tRNS_to_alpha@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_set_longjmp_fn@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_set_gray_to_rgb@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_set_read_user_transform_fn@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_set_filler@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_get_valid@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_get_error_ptr@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_destroy_read_struct@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_get_IHDR@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_set_palette_to_rgb@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_set_packing@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_set_read_fn@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_create_info_struct@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_read_end@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_read_update_info@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_set_expand_gray_1_2_4_to_8@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_read_image@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_read_info@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_error@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_set_strip_16@PNG16_0'
collect2: error: ld returned 1 exit status
Makefile:2343: recipe for target 'hepmc2pileup' failed
make: *** [hepmc2pileup] Error 1
make: *** Waiting for unfinished jobs....
/usr/bin/ld: warning: libpng16.so.16, needed by //home/sayan/anaconda2/lib/libfreetype.so.6, not found (try using -rpath or -rpath-link)
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_create_read_struct@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_set_interlace_handling@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_get_io_ptr@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_set_tRNS_to_alpha@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_set_longjmp_fn@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_set_gray_to_rgb@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_set_read_user_transform_fn@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_set_filler@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_get_valid@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_get_error_ptr@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_destroy_read_struct@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_get_IHDR@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_set_palette_to_rgb@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_set_packing@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_set_read_fn@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_create_info_struct@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_read_end@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_read_update_info@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_set_expand_gray_1_2_4_to_8@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_read_image@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_read_info@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_error@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_set_strip_16@PNG16_0'
collect2: error: ld returned 1 exit status
Makefile:2343: recipe for target 'pileup2root' failed
make: *** [pileup2root] Error 1
/usr/bin/ld: warning: libpng16.so.16, needed by //home/sayan/anaconda2/lib/libfreetype.so.6, not found (try using -rpath or -rpath-link)
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_create_read_struct@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_set_interlace_handling@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_get_io_ptr@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_set_tRNS_to_alpha@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_set_longjmp_fn@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_set_gray_to_rgb@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_set_read_user_transform_fn@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_set_filler@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_get_valid@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_get_error_ptr@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_destroy_read_struct@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_get_IHDR@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_set_palette_to_rgb@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_set_packing@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_set_read_fn@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_create_info_struct@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_read_end@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_read_update_info@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_set_expand_gray_1_2_4_to_8@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_read_image@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_read_info@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_error@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_set_strip_16@PNG16_0'
collect2: error: ld returned 1 exit status
Makefile:2343: recipe for target 'lhco2root' failed
make: *** [lhco2root] Error 1
/usr/bin/ld: warning: libpng16.so.16, needed by //home/sayan/anaconda2/lib/libfreetype.so.6, not found (try using -rpath or -rpath-link)
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_create_read_struct@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_set_interlace_handling@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_get_io_ptr@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_set_tRNS_to_alpha@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_set_longjmp_fn@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_set_gray_to_rgb@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_set_read_user_transform_fn@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_set_filler@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_get_valid@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_get_error_ptr@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_destroy_read_struct@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_get_IHDR@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_set_palette_to_rgb@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_set_packing@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_set_read_fn@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_create_info_struct@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_read_end@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_read_update_info@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_set_expand_gray_1_2_4_to_8@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_read_image@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_read_info@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_error@PNG16_0'
//home/sayan/anaconda2/lib/libfreetype.so.6: undefined reference to `png_set_strip_16@PNG16_0'
collect2: error: ld returned 1 exit status
Makefile:2343: recipe for target 'root2lhco' failed
make: *** [root2lhco] Error 1

How can I fix this problem?

Change History (4)

comment:1 Changed 4 months ago by pavel

  • Description modified (diff)

comment:2 Changed 4 months ago by pavel

Closing as a duplicate of #1304.

comment:3 Changed 4 months ago by pavel

  • Resolution set to fixed
  • Status changed from new to closed

comment:4 Changed 4 months ago by pavel

How can I fix this problem?

Please check ticket #1304 for a proposed solution. Here is a link to the ticket #1304:
https://cp3.irmp.ucl.ac.be/projects/delphes/ticket/1304

Note: See TracTickets for help on using tickets.